SaaS CMS has officially launched! Learn more now.

Maintenance page


I tried to setup maintenance page as it is described in documentation here:

But at deployment to Integratoin environment it still shows default IIS 403 page. 

Are there any additional steps that must be done?

Edited, Aug 01, 2022 13:18

Are you using the Deployment API, usually with integration you'd not need it but as you deploy to preproduction and production using slots you'd set the flag in the Deployment API for using the maintenance page. Or if in the Pass Portal check the box

Aug 01, 2022 15:26

Also are you on .NET 5/6 or .NET Framework versions?

Aug 01, 2022 15:27

> Also are you on .NET 5/6 or .NET Framework versions?

Net5 version.

>  you'd set the flag in the Deployment API for using the maintenance page

thanks, I did forget about that option at deployment, I am going to try to use it.

To be honest, we are having problems with azure logs and for whatever reason support proposed to set up maintenance page. I don't see much connection between logs and maintenance page, but here I am.

Aug 02, 2022 7:00
Scott Reed - Aug 02, 2022 8:05
The log streaming doesn't work very well for starting issues now as the .NET 5 application in containerized behind the scenes in a docker image which makes it hard to troubleshoot issues but (at least for Integration) if you go to the webapp you can go to troubleshoot on the main blade and access the application logs which can give more information.
klappo - Aug 03, 2022 7:58
Thanks, but meh, application logs are not usable. I have been struggling for months to fing reliable and convinient way to track logs, and still no solution

As a result: we use deployment api and I had to specify deployment options to make maintenance page appear

$options= @{
   // ... other parameters

    // Actually does the trick
    UseMaintenancePage = $true 
    // Should be false,  because direct deploy does not swap slots in Azure
    DirectDeploy = $true

$deploy = Start-EpiDeployment @options
Edited, Aug 03, 2022 8:02
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.