SaaS CMS has officially launched! Learn more now.

Error when adding payment method after applying EPiServer 7.5 update 4

Vote:
 

Hi,

I've applied EPiServer 7.5 update 4 to Commerce Manager using the instructions found on this page http://world.episerver.com/Documentation/Items/Installation-Instructions/Installing-EPiServer-updates/. Then, when I try to add a new payment method I get an application error, which is shown below.

Cannot find a type of name Mediachase.Commerce.Orders.IPaymentGateway within the plugins or the common library.

[ArgumentException: Cannot find a type of name Mediachase.Commerce.Orders.IPaymentGateway within the plugins or the common library.]
System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg) +14543138
System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type) +622
Mediachase.Web.Console.Common.RemoteLoader.GetSubclasses(String baseClass) +0
Mediachase.Web.Console.Common.ReflectionHelper.GetClassesBasedOnTypeInSiteDir(Type assemblyType, String path) +455
Mediachase.Commerce.Manager.Order.Payments.Tabs.PaymentMethodEditBaseTab.BindClassNames() +220
Mediachase.Commerce.Manager.Order.Payments.Tabs.PaymentMethodEditBaseTab.BindForm() +75
System.Web.UI.Control.LoadRecursive() +71
System.Web.UI.Control.LoadRecursive() +190
System.Web.UI.Control.LoadRecursive() +190
System.Web.UI.Control.LoadRecursive() +190
System.Web.UI.Control.LoadRecursive() +190
System.Web.UI.Control.LoadRecursive() +190
System.Web.UI.Control.LoadRecursive() +190
System.Web.UI.Control.LoadRecursive() +190
System.Web.UI.Control.LoadRecursive() +190
System.Web.UI.Control.LoadRecursive() +190
System.Web.UI.Control.LoadRecursive() +190
System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +3178

What could be the cause of this problem?

Kind regards,

Simon

#80895
Feb 04, 2014 14:46
Vote:
 

Hi Simon

I'm getting the same error. Did you find a solution to the problem?

 

Regards

Anders

#81171
Feb 11, 2014 10:20
Vote:
 

Hi,

The problem happened with Commerce Manager update 4 (.446.x) and was registered as a bug. This was fixed in next release (in testing phase). We understand that this is causing trouble and will release updates ASAP.

Thank you for your understanding and co-operation.

Regards.

/Q

 

#81189
Feb 11, 2014 11:40
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.