Try our conversational search powered by Generative AI!

Stuck on login page in Quicksilver on Azure


I am trying to deploy Quicksilver on azure. All was good until first run after deploy.

I am stuck on login page. Default credentials do not work.
The adress bar shows adress :

Does that mean I am stuck on migrate and some other error is messing the migrate process?

I have tried to set  <allow users="*"/> in web.config but that does nothing.

Edited, Sep 05, 2019 18:02

The default credentials should work. What credentials are you using?

You can also add AutoMigrateEPiServer to appSettings with value = true, so it will migrate automatically for you. Once it's done you can access the site as normal

Sep 06, 2019 9:07

Hi Quan,

I am using as credentials. Those are wrong credentials, according to quicksilver.

Adding AutoMigrateEPiServer to appSettings in web.config does nothing.

I was using this guide

but it is not very good. Should I do the process for all projects in quicksilver? For Manager and for Shared?

There was no information that I should add two databases to azure. It is obvious after the fact, but not when doing this for the first time.

Among other things.

Is there a way to completely turn off credentials validation in quicksilver? Just to finish this process? I have changed authorisation nodes to allow users="*" but that did nothing.

Edited, Sep 06, 2019 9:58

Is there a way to check what exactly is goig on at this state of the site initialisation process? Should I check for some specific rows of data in the database? Should the dbo_MigrationHistory table contain someting else than InitialCreate? Where could I find logs from Update-EpiDatabase script? Are thre any?

I am really stuck here. I dont know what is going on, What went wrong and what went right.

Sep 06, 2019 11:55

I have managed to get it to work!

I have deleted existing databases for commerce and cms and recreated them in azure.

I have added two scripts for updating databases to publish settings.

I have added my IP to azure Firewall and have run Update-EPiDatabase

After that the site is still stuck on login page.

So I have added

<allow users="*"/>

to manager web.config and moved the same piece of code in Site web.config to the top most position. And I have changed

<authentication mode="None">


<authentication mode="Forms">

And that gave me a 502 error after one more publish. But after a refresh I finally have clean Quicksilver with content.

But now I cannot login to the dashboard. Any credentials I enter are incorrect.

I have added admin user:

but still, Quicksilver is adamant that this user does not exist.

Did someone managed to install this Quicksilver on azure with any success? I could really use some pointers here.

Edited, Sep 06, 2019 15:19

There is a script (SetupDatabases.cmd) file that should be run to populate Quicksilver database when running on eg local server. 

There are also two scripts for two databases in packages.

When installing in local environment, after running SetupDatabases.cmd everything is ok, commerce database is populated and

can be used to login to the dashboard.

But when using the two scripts from packages, when installing on the azure servers, this user does not exists and logging in is not possible.

Should I run the first script on azure server? Is this even possible?

Sep 06, 2019 16:47

I think I have figured it out. It is really obvious now, but wasn't at the beggining, when I did not know what was really happening. Also, the decumentation should be a bit more precise. For example what resources need to be added to azure for the manager part and waht can be shared between the two.

There are three procedures in the SetupDatabases.cmd: Create cms database, create commerce database and creating users for it.

The documentation states that I should add two scripts to the deploy setup, both create databses, ommitting the step responsible for user creation. So add the aspnet_identity.sql file to the commerce database in the database updates setting and do it after the database creation script.

Sep 20, 2019 14:17
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.