Try our conversational search powered by Generative AI!

Upgrading EPiServer 5 to 6


Hey everyone,

I'm currently in the process of upgrading a CMS site from version 5 to version 6 and am having a couple of problems.

I ran the upgrade tool from the Deployment Center and that all went smoothly. I've also coppied all of the DLLs from the C:\Program Files\EPiServer\CMS\6.0.530.0\bin location into my DLLs folder which is being references by Visual Studio.

The problem i'm getting is when running the site. I get the following error message:

Cannot resolve dependencies for the following module(s)

What have I missed? EPiServer.Cms.Shell.UI is in my list of references but I'm guessing there's something else I need to copy over also?

Cheers for the help!


Apr 23, 2010 12:45

I had this issue on WIndows 7.
Don't remember if it worked by just running the installation of CMS6 as admin and then run Deplyment Center as Admin.

This is what I did that does for sure work:

1. Turn of UAC
2. Repair the CMS 6 installation
3. Run the upgrade again.

Again this was on Windows 7.


Apr 23, 2010 14:22

Hi Morten,

Thanks for replying and your sugestions.

I eventually tracked the problem down to the fact that the bin folder within the "6.0.530.0" (C:\Program Files\EPiServer\CMS\6.0.530.0\bin) folder, doesn't actually contain all the required DLLs for EPiServer to work correctly.

I've written about it here for others in future:

Thanks again for your help.


Edited, Apr 23, 2010 15:58

Hello folks,


We noticed that some of the newer version assemblies added as a reference doesn't get copied in the project bin folder after compilation instead they are referred from machine GAC. We uninstalled EPiServer CMS 6 and then re-referred these assemblies from common folder. We explicitly set the CopyLocal property to True for all the new assemblies so that the referred assembly gets copied into the bin once the build is successful. This solves our problem.

We tried this on following environment - Windows XP SP3, IIS 5.1, Visual Studio 2008




Feb 15, 2011 13:04
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.