Try our conversational search powered by Generative AI!

Unified File System

Ive implimented the UFS and managed to set permissions the way we want them - but now for some reason all pictures are not being served that exist in the /upload/ folder which is now virtualShare=True, Physical Path C:\dok\uload. In admin mode under File Management I can use the "show thumbnails" to display the picture and I have set security rights to allow everyone, web readers, wed admins, editors etc.. anyone that wants to should be able to see those pictures. But when browsing the site i get the X picture missing graphic. Is there any reason for this?
Feb 14, 2005 10:31
I made a virtual folder in IIS pointing to the same path but I dont feel this to be the right solution... but the pictures do show and security settings are holding... now during testing I got an unnatractive "Server error in / - you are not authorised to create a subdirectory in "/upload/testing"...* is there a way to configure it to a nicer looking "sorry!" message? I get this error when I try to "Insert image from file..." and try to add a folder. Using the File Manager I dont even get the "add folder" button as its disabled (because ive only given read access to the folder.) If I try to add a file I get an equally unattractive error "you are not authorised to access directory "/upload/testing". Adding a file should work as all im doing is adding an image to my page from the files that exist already?!
Feb 14, 2005 10:59
You should not create a virtual directory with the same name in IIS. The resulting behaviour is hard to predict, and is not how the Unified Filesystem was ment to be used. If you try to surf directly to one of the images in your /upload/ directory, if you've turned off the "friendly" error messages, or surfing on localhost, you should see an errormessage. When browsing the thumbnails, EPiServer generates these on the fly, puts them under util/temp. The page serving them is util/image.aspx. However, when displaying files using the "real" url (/upload/myimage.gif), the files are served by the util/getfile.ashx. Note the extension. Many automated deploymentscripts fail to copy this file, as .ashx files are seldom used in your own projects, and easy to forget. /Steve
Feb 14, 2005 12:24
Thanks I will look into it.
Feb 14, 2005 12:31
util/getfile.ashx exists in the right place
Feb 14, 2005 12:34
...and browsing from another machine than localhost I get windows popup login followed by the nicer episerver "there has been an error" where you can send a msg to the administrator. I guess that is what should happen as per normal?
Feb 14, 2005 12:37
You should not get the login popup, if you have granted read to the Anonymous account. What error message do you get when you go surf to an image from localhost? /Steve
Feb 14, 2005 13:28
I think I found the problem. I was getting an error 500 "not found" - but the error was pointing to the fact that my 404 error page was not pointing at /util/notfound.aspx but pre-upgrade from 3.5 value /system/notfound.asp. Pictures now show at least. I still get the login popup as before. IIS_USR has read permission on the whole C:\dok\upload folder. All users (everyone group) have read permission on the /upload/ folder in admin mode under File Management. Im using win2000 at the moment as development machine but production and test are server 2003 and have not had any changes made with regard to UFS yet. /John
Feb 14, 2005 13:52
Ah, Unified File System needs the 404 hander to be an aspx file, in order to get the BeginRequest event which is used to find out if this request is for a file. For windows 2000, you need to grant access rights to the account. Under windows 2003 this typically is the special Network Service account, unless you have told IIS 6.0 otherwise. See the EPiServer 4 Operators Guide in for more information. /Steve
Feb 14, 2005 14:14
Does the UFS handle swedish characters? Some images are served when there are no swedish characters in the folder names and others that have sweidsh characters dont work.
Feb 15, 2005 11:11
Ive posted this last question as a sepearte issue in the problems and bugs forum as nobody has answered it here.
Mar 11, 2005 15:19
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.