Try our conversational search powered by Generative AI!

Migration Tool - Completes successfully but Users/roles are not visible in Admin-mode


I am migrating an EPiServer CMS 4.62web site to EPiServer CMS 5 R2.
The migration tool completes successfully but users are not migrated.
They do exist in the database but they are not visible in admin mode when searching for them. The accounts are not locked out.

Aug 11, 2009 15:55

Are the Sql membership and role providers configured for use (default provider or one of the providers in the multiplexer if it is default)?

Aug 11, 2009 16:27

Yes they are. See below.


<roleManager enabled="true" defaultProvider="SqlServerRoleProvider" cacheRolesInCookie="true">

<clear />

<add name="SqlServerRoleProvider" connectionStringName="EPiServerDB" applicationName="application" type="System.Web.Security.SqlRoleProvider, System.Web, Version=, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" />


<membership defaultProvider="SqlServerMembershipProvider" userIsOnlineTimeWindow="10">
<clear />

<add name="SqlServerMembershipProvider" type="System.Web.Security.SqlMembershipProvider, System.Web, Version=, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" connectionStringName="EPiServerDB" requiresQuestionAndAnswer="false" applicationName="application" requiresUniqueEmail="true" passwordFormat="Hashed" maxInvalidPasswordAttempts="5" minRequiredPasswordLength="7" minRequiredNonalphanumericCharacters="0" passwordAttemptWindow="10" passwordStrengthRegularExpression="" />


Aug 11, 2009 17:17
Could you check the log file from the Migration Tool? Also - could you see if the migration tool has generated the .csv file with the new passwords (should be located inside the migration tool install folder).
Aug 12, 2009 9:14


There is a generated ".csv" file with the users and randomly generated passwords.
These user accounts are added to the database (standard aspnet -tables).
But still they are not visislbe when I am in admin-mode?

The migration tool log (MigrationLog.log) reports no errors.
[2009-08-11 09:10:20][Information] Migration Completed.

Maybe the best way is to recreate the users (either via sql-script) or via admin-mode.
Thank you for your help.

Aug 12, 2009 9:22

You posted above that you are using SqlMembership and RoleProvider as default providers.

Since you obvoiusly have access to admin I assume that you are logged in with your local administrator windows account, i.e your're either running WindowsAuthentication og MultiPlexing?

Just to be absolutely sure - you are looking at the correct web.config file? This is the web.config inside the version 5 site you pointed to when starting the  migration tool - not the web.config file from the website you converted.

Aug 12, 2009 9:31

Yes. The web.config file I am working with is the web.config file for the CMS 5
web site.
I am working in a locally setup vmware-environment and what I have done to get
in to admin mode is not by logging in but instead commenting out the following lines
in web.config for the CMS 5 web site.

<!-- This is done both for edit and admin modes 
 I just comment out the lines below.
No other users have access to the system.

<!-- <allow roles="WebEditors, WebAdmins, Administrators" />-->
<!--<deny users="*" />-->
<allow users="*" />

So I am not really logging in to the web site I am just bypassing the
<deny users> thing here. But still I should be able to see the users I think.
I have tried login with multiple accounts from the csv-file but none of them works.
It just says "Login failed".

Thank you for very much for your fast reply.Smile

Aug 12, 2009 9:44

It seems I have to manully create new groups (roles) in admin mode.
For example I had a group called "WebAdmins" on the old web site.

I recreate this new group through admin mode. By using the following sql-query:

update dbo.aspnet_UsersInRoles set RoleId='[new GUID for WebAdmins]' where RoleId='[old GUID for group WebAdmins]'

All user accounts that I cannot see in admin-mode but do exist in the database gets
the new role (same purpose with the new role as the old one).
After this It seems that the "Set Access Rights" page works better.
Suddenly It knows which roles have access rights to which pages.

Do you have an idea to why this problem occurs?

Edited, Aug 12, 2009 9:59

Ok, your .csv file and the migration log indicates that the users have been migrated.

But the SqlMembership Provider cannot find any users (even though you can see them in the database). Could you check to see that the providers are configured with the correct database (check connectionStringName vs connectionStrings).

Then try to create a new user, and see if you can locate the same user inside the database.

Aug 12, 2009 11:04
Yes. I have now double checked the connection string in connectionstrings.config.
It points to the correct database (the migrated one).

I have created both new roles and new users and they appear in the same database
as the user accounts that is not shown in admin-mode. The user account that do work exist in the same tables as the user accounts that do not work.

Creating new user accounts and groups (same names as the old ones)
seem to have solved the problem. For what I can see the access rights are
correct for the pages that do exist.

Now I must create the rest of the accounts that did not work.Surprised

Thank you for your help, have a nice day. Smile
Aug 12, 2009 11:23
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.