Try our conversational search powered by Generative AI!

Commerce sample site EPiServer 7.5 - Error - More than one content model is assigned the guid ...


I get the error message below when installing the Commerce sample site in EPiServer 7.5.


Started a transacted install
Application name = EPiServerCommerceManager
Copying C:\Program Files (x86)\EPiServer\CMS\7.5.394.2\Install\Modules\EPiServer Commerce Sample 7.5.394.2\Application to C:\EPiServer\ExampleEPiServerSite\wwwroot
Copying C:\Program Files (x86)\EPiServer\CMS\7.5.394.2\Install\Modules\EPiServer Commerce Sample 7.5.394.2\Binaries to C:\EPiServer\ExampleEPiServerSite\wwwroot\bin
Unzip import package
Copying C:\Program Files (x86)\EPiServer\CMS\7.5.394.2\Install\Modules\EPiServer Commerce Sample 7.5.394.2\Install to C:\Sample1322945394\Tools\DataFiles
Importing StarterDemoDepartmental package
Entering commit phase
Started a transacted install
Adding currency rates for sample
Adding market payment methods for sample
Importing asset contents
An error has occured and the transaction will be rolled back
More than one content model is assigned the guid ee3bd195-7cb0-4756-ab5f-e5e223cd9820
More than one content model is assigned the guid ee3bd195-7cb0-4756-ab5f-e5e223cd9820

An unhandled error has occured:
More than one content model is assigned the guid ee3bd195-7cb0-4756-ab5f-e5e223
When executing

At C:\Program Files (x86)\EPiServer\CMS\7.5.394.2\Install\Modules\EPiServer Com
merce Sample 7.5.394.2\Install\Install Commerce Sample.ps1:225 char:22
+ Add-EPiServerData <<<< -ImportSource $sampleAssetsDataFile -DestinationD
irectory $selectedWebApplication.PhysicalPath -VirtualDirectory $selectedWebApp
lication.ApplicationName -DestinationType "ExplicitPage" -DestinationPage $glob
alMediaRoot -TransactionTimeout (New-TimeSpan -minute 60)


At C:\Program Files (x86)\EPiServer\CMS\7.5.394.2\Install\Modules\EPiServer Commerce Sample 7.5.394.2\Install\Install Commerce Sample.ps1:225 char:22
+ Add-EPiServerData <<<< -ImportSource $sampleAssetsDataFile -DestinationDirectory $selectedWebApplication.PhysicalPath -VirtualDirectory $selectedWebApplication.ApplicationName -DestinationType "ExplicitPage" -DestinationPage $globalMediaRoot -TransactionTimeout (New-TimeSpan -minute 60)
EPiServer.DataAbstraction.RuntimeModel.SynchronizationException: More than one content model is assigned the guid ee3bd195-7cb0-4756-ab5f-e5e223cd9820
at EPiServer.DataAbstraction.RuntimeModel.ContentModelValidator.ThrowSynchronizationException(String msg)
at EPiServer.DataAbstraction.RuntimeModel.ContentModelValidator.CheckForDuplicateContentModelGuids(IEnumerable`1 models)
at EPiServer.DataAbstraction.RuntimeModel.ContentModelValidator.Validate(IEnumerable`1 typeModels)
at EPiServer.DataAbstraction.RuntimeModel.ContentTypeModelRegister.Validate(ContentModelValidator modelValidator)
at EPiServer.DataAbstraction.RuntimeModel.ContentTypeModelScanner.Sync(Boolean commitChanges)
at EPiServer.Initialization.ModelSyncInitialization.Initialize(InitializationEngine context)
at EPiServer.Framework.Initialization.ModuleNode.<>c__DisplayClass5.<Initialize>b__4()
at EPiServer.Framework.Initialization.ModuleNode.Execute(Action a, String key)
at EPiServer.Framework.Initialization.ModuleNode.Initialize(InitializationEngine context)
at EPiServer.Framework.Initialization.InitializationEngine.InitializeModules()
at EPiServer.Framework.Initialization.InitializationEngine.Initialize(HostType hostType)
at EPiServer.Framework.Initialization.InitializationModule.Initialize(HostType hostType)
at EPiServer.Framework.Initialization.InitializationModule.FrameworkInitialization(HostType hostType)
at EPiServer.Install.CMS.Common.EPiServerCMSWrapper.InitalizeEPiServer(String webConfigPath)
at EPiServer.Install.CMS.Common.EPiServerCMSWrapper.Initialize(String destinationPath, String virtualDirectory)
at EPiServer.Install.CMS.Common.EPiServerCMSWrapper.Initialize(String destinationPath, String virtualDirectory)
at EPiServer.Install.Common.AppDomains.RunInAppDomainInstaller.Install(IDictionary stateSaver)
at EPiServer.Install.InstallationManager.Install(Installer installer)
at EPiServer.Install.CMS.Modules.ModulesInstallationManager.ImportData(InstallationManager installationManager, String destinationDirectory, String virtualDirectory, String importSource, DatabaseDestination destination, TimeSpan transactionTimeout)
at EPiServer.Install.CMS.Modules.CmdLets.AddEPiServerData.ProcessRecord()
at System.Management.Automation.Cmdlet.DoProcessRecord()
at System.Management.Automation.CommandProcessor.ProcessRecord()


Dec 05, 2013 13:58

It would seem that you cannot install the alloy sample site and the commerce sample site together as there is a guid conflict between the two sites or components within the two sites.

Dec 10, 2013 11:34

I'm having exactly the same error here as well

Is there a way to delete the content with this guid from DB directly or work around this issue in some other way?

Dec 10, 2013 17:55

I tried uninstalling the Alloy sample site but the problem remained, my install was a local development install so it wasn't a problem for me to uninstall and reinstall the whole package again ommitting the alloy sample site and only installing the new commerce sample site.

Dec 10, 2013 18:10


The problem happens if you install both Commerce Sample site and Alloy template to a (Commerce) site. This is not recommended. But having that error is indeed a bug - we fixed recently.



Jan 15, 2014 11:14

I'm getting this error on one environment only. Same repo, same db. 

We have not installed the Commerce Sample Site but have installed the Alloy template. 

We are on 7.6.  


Edited, Mar 27, 2014 18:48

Removed the last post as it was the result of a namespacing misadventure.

EDIT: On second thoughts it may be useful to describe what happened. I was getting the same GUID error as above and could not clear it. The problem was that I'd changed the namespace of the project but not cleared out the bin folder. There were consequently two dlls for the site, and each one was adding the content types to the database, resulting in the GUID collision. Dumb, but I'll leave this here in case anyone else has a similar bear-of-little-brain moment.

Edited, Apr 10, 2014 12:28

This bug seems to be present still in the current available download from EPiServer (2014-05-13). A bit dissapointing really, since the options are there when installing a Commerce Site. If its not recommended to install both the CMS-site and Commerce at the same time, just remove those options from Depolyment center when a new site is created.


May 13, 2014 10:10


You will get this error if you have renamed your assembly.

Please clear all .dll's from your bin folder and delete all temporary files from "Temporary ASP.NET Files".

Jun 24, 2015 13:05

That fixed that issue for me.

Jul 15, 2015 13:01
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.