Cannot delete Related Entities in Commerce 14.3.1

Vote:
 

Api method seems to get called with "undefined" instead of the querystring like "?referenceId=49__CatalogContent&dojo.preventCache=1654139903825" it is supposed to have. 

#281254
Jun 02, 2022 3:19
Vote:
 

Does this happen for all variants or just this particular one?

Another seemingly random question: did you recently upgrade any of the commerce packages?

#281437
Jun 06, 2022 10:54
Vote:
 

Hi, yes it is for all variants and products. 
I did indeed just upgrade to 14.3.1.. should I start a new commerce db?

#281438
Jun 06, 2022 11:05
Vote:
 

It could be this particular view in the _protected folder has corrupted. Sometimes happens during an upgrade.

Try reinstalling the Commerce nuget packages using -reinstall in package manager. If that fails then try reinstalling your entire nuget package collection.

This *might* not be the issue but worth a shot. I've had undefined messages thrown at me and ended up being a shell module corruption.

#281439
Jun 06, 2022 11:16
Vote:
 

Sorry, nothing has worked. Reinstalled all packages, fresh commerce database, same result. 
Anyone else on 14.3.1 this still works for?

#281523
Jun 08, 2022 1:59
Vote:
 

Fixed in Commerce 14.4

#281531
Jun 08, 2022 3:50
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.