Custom Property blocks Forms editing


Trying to implement the StringList Custom property from the Alloy example site in my own project. I have created/copied the PropertyStringList.cs, StringList.cs (EditorDescriptors), StringList.ascx and StringList.js (dojo) and the soultion builds ok. But when on a page that uses the StringList property I can't switch to Forms editing mode. 

If I remove the StringList.cs (EditorDescriptors) the Forms editing works again. The only change i have made was to rename the ClientEditingClass in the StringList.cs and StringList.js.

Tried to activate the EpiServer log but even on All I can't get anything in the log when switching to forms editing.

Why does it not work?

Oct 22, 2013 14:52

Ok, found that the url to the js file is wrong when dojo tries to fecth it. The url becomes EPiServer/Shell/1.0.456/ClientResources/dtk/capo/editors/StringList.js.

How do I fix that.? Found the module.config file in the root that seems to have something to do with this but not really sure how.

Oct 22, 2013 15:11

And there comes the solution. Editing the module.config file to reflect my solution solved the issue.

Oct 22, 2013 15:29
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.