Virtual Happy Hour this month, Jun 28, we'll be getting a sneak preview at our soon to launch SaaS CMS!

Try our conversational search powered by Generative AI!

Upgrade error from 6R2 to 7.0

Vote:
 

Server Error in '/' Application.Could not load type 'EPiServer.Shell.InitializationModule' from assembly 'EPiServer.Shell, Version=6.2.267.1, Culture=neutral, PublicKeyToken=8fe83dea738b45b7'.Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. 

Exception Details: System.TypeLoadException: Could not load type 'EPiServer.Shell.InitializationModule' from assembly 'EPiServer.Shell, Version=6.2.267.1, Culture=neutral, PublicKeyToken=8fe83dea738b45b7'.

Source Error: 

[No relevant source lines]


Source File: c:\Windows\Microsoft.NET\Framework64\v4.0.30319\Temporary ASP.NET Files\root\0a09daa4\2d581c07\App_global.asax.0.cs    Line: 0 

Stack Trace: 

[TypeLoadException: Could not load type 'EPiServer.Shell.InitializationModule' from assembly 'EPiServer.Shell, Version=6.2.267.1, Culture=neutral, PublicKeyToken=8fe83dea738b45b7'.]
   EPiServer.Framework.Initialization.InitializationEngine.SetupAssemblyTypeScanner() +948
   EPiServer.Framework.Initialization.InitializationEngine.ScanAssemblies() +21
   EPiServer.Framework.Initialization.InitializationModule.Initialize(HostType hostType) +291
   EPiServer.Framework.Initialization.InitializationModule.FrameworkInitialization(HostType hostType) +93
   EPiServer.Global..ctor() +102
   EPiServer.Templates.Global..ctor() +40
   ASP.global_asax..ctor() in c:\Windows\Microsoft.NET\Framework64\v4.0.30319\Temporary ASP.NET Files\root\0a09daa4\2d581c07\App_global.asax.0.cs:0

[TargetInvocationException: Exception has been thrown by the target of an invocation.]
   System.RuntimeTypeHandle.CreateInstance(RuntimeType type, Boolean publicOnly, Boolean noCheck, Boolean& canBeCached, RuntimeMethodHandleInternal& ctor, Boolean& bNeedSecurityCheck) +0
   System.RuntimeType.CreateInstanceSlow(Boolean publicOnly, Boolean skipCheckThis, Boolean fillCache, StackCrawlMark& stackMark) +159
   System.RuntimeType.CreateInstanceDefaultCtor(Boolean publicOnly, Boolean skipCheckThis, Boolean fillCache, StackCrawlMark& stackMark) +256
   System.Activator.CreateInstance(Type type, Boolean nonPublic) +127
   System.RuntimeType.CreateInstanceImpl(BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes, StackCrawlMark& stackMark) +14259449
   System.Activator.CreateInstance(Type type, BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes) +200
   System.Activator.CreateInstance(Type type, BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture) +28
   System.Web.HttpRuntime.CreateNonPublicInstance(Type type, Object[] args) +83
   System.Web.HttpApplicationFactory.GetSpecialApplicationInstance(IntPtr appContext, HttpContext context) +312
   System.Web.Hosting.PipelineRuntime.InitializeApplication(IntPtr appContext) +475

[HttpException (0x80004005): Exception has been thrown by the target of an invocation.]
   System.Web.HttpRuntime.FirstRequestInit(HttpContext context) +12968244
   System.Web.HttpRuntime.EnsureFirstRequestInit(HttpContext context) +159
   System.Web.HttpRuntime.ProcessRequestNotificationPrivate(IIS7WorkerRequest wr, HttpContext context) +12807949
#87520
Jun 16, 2014 13:05
Vote:
 

Check that all references in the projects points to dlls of version 7+ after upgrade, and preferrably not to the GAC...

#87524
Jun 16, 2014 13:21
Vote:
 

Daniel is now fixed, but i have the issue like this http://world.episerver.com/Modules/Forum/Pages/thread.aspx?id=87527&pageIndex=1

Give some tips to fix this issue. Thanks in advance.

#87555
Jun 17, 2014 9:47
Vote:
 

I have upgraded to 7 when upgrading to 7.5 in the step Install EPiServer.CMS.Core i am getting error saying that Install failed. Rolling back
Failed to add reference to System.core. Please make sure that it is the GAC. Any idea how could i resolve this.

#87630
Jun 18, 2014 13:27
Vote:
 

Gayathri,

Were you able to get around this issue?

I'm having the same issue when trying to update to 7.13.3 via nuget.

#90687
Sep 16, 2014 11:10
Vote:
 

@OerjanH

The project was referring to the GAC not referring to references for that project.I fixed that issue.

#90688
Sep 16, 2014 11:15
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.