Don't miss out Virtual Happy Hour this Friday (April 26).

Try our conversational search powered by Generative AI!

Search Service over SSL (for edit mode)

Vote:
 

Ok guys, running the latest EPiServer 8 with all the latest patches. 

I was having the following problem. The search in edit mode for blocks and pages wasnt working. 

So i didnt had the search service installed and activated: http://world.episerver.com/Modules/Forum/Pages/Thread.aspx?id=71532


Now i did that on my dev environment and my site in indexed and i can search the pages now perfectly.

if i access: http://hr.local/IndexingService/IndexingService.svc  i can perfectly see the 'Endpoint not found.' message.


    
      
        
      
    
    
      
    
  

Now i deployed this to our test server where the site runs on SSL .. And i tried to change the BaseUri to the url on the test environment like so


    
      
        
      
    
    
      
    
  

if i go to https://hr.test.servername.nl/IndexingService/IndexingService.svc  i get

Incorrect link

The link you gave does not work, either because the page it points to has been deleted or moved. If you clicked on a link, please inform the site’s webmaster that the link is faulty.

[HttpException: There was no channel actively listening at 'https://hr.test.servername.nl/IndexingService/IndexingService.svc'. This is often caused by an incorrect address URI. Ensure that the address to which the message is sent matches an address on which a service is listening.]
   at System.Runtime.AsyncResult.End[TAsyncResult](IAsyncResult result)
   at System.ServiceModel.Activation.HostedHttpRequestAsyncResult.End(IAsyncResult result)
   at System.Web.HttpApplication.CallHandlerExecutionStep.OnAsyncHandlerCompletion(IAsyncResult ar)

[Inner exception EndpointNotFoundException: There was no channel actively listening at 'https://hr.test.servername.nl/IndexingService/IndexingService.svc'. This is often caused by an incorrect address URI. Ensure that the address to which the message is sent matches an address on which a service is listening.]
   at System.ServiceModel.Activation.HostedHttpTransportManager.HttpContextReceived(HostedHttpRequestAsyncResult result)
   at System.ServiceModel.Activation.HostedHttpRequestAsyncResult.HandleRequest()
   at System.ServiceModel.Activation.HostedHttpRequestAsyncResult.BeginRequest()

Now if i would run http://hr.test.servername.nl/IndexingService/IndexingService.svc  (without SSL), i get the correct message "Endpoint not found."

So what is happening here? Why doesnt this work on SSL. I also have multiplesitebinding enabled set to true.

The test server is running on windows server 2008 R2.

Does any of you have had this experience before?

#120933
Apr 28, 2015 12:23
Vote:
 

Damn.. how didnt i found that valuable piece of information.. 

Thanks Dejan for pointing me in the right direction.. 

<security mode="Transport">
     <transport clientCredentialType="None"></transport>
</security>

was all i needed to add... 

also this is nice to know for people:

#120940
Apr 28, 2015 14:40
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.