Upgrading from CMS 5 R1 SP3 to CMS 5 R2



I am upgrading a site that is currently on R1 SP3 up to R2.

When I try to perform the upgrade, it complains that the source and destination must have the same root.

I have found that the installer expects the website folder to be on the same drive as the EPiServer installation files (e.g. C:\)

The installation that we have has the website folder on the C:\ drive and the operating system (along with the program files folder) is on the F:\ drive (don't ask!)

Copying the website folder to the F:\ drive fixed the problem and the installation worked fine.

My question is this:
Is this suposed to be the case?  Does the Website folder have to be on the same drive as the EPiServer program files?



Apr 08, 2009 13:27

No, its fixed in the SP1 installer. I think there is a workaround somewhere on the forum for the R2 installer.


Apr 08, 2009 14:39


Thanks for the reply

It was the SP1 installer that I was using.  It may be that there is a newer release of the SP1 installer.

When the time comes to perform the same task again, I will ensure that I download the latest installer.



Apr 08, 2009 15:04
I had the same issue, but solved it by moving the entire filestructure to C: and the do the upgrade process. Then; move the files back to F: or whatever and change the paths to the program files in web.config
Edited, Apr 15, 2009 13:14

An Update:

When I performed the same action again, I had the same problem.  It's a bit of a pain, but nothing that can't be lived with.

Just a heads up as well.  When you are upgrading a site from CMS 5 R1 SP3 to R2, you must be on a PC/Server running IIS6.  So be prepared to move the entire site to another machine if you are using Vista!

P.s.  Hats off to the EPiServer Development Team.  The new Deployment Center is a huge leap forward.  Thanks!

Apr 21, 2009 12:22

Basically the upgrade scripts for R1 SP3 -> R2 has this bug, independent of the installer. You should not get it while upgrading from R2 to R2 SP1. Otherwise, please let me know so we can revisit this bug.

The bug is that it moves files to the temp directory to handle transactions, so as long as you have the temp directory on the same drive as the site it works.

Thanks for the feedback.


Apr 22, 2009 17:24
Edited, May 06, 2009 14:42
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.