SaaS CMS has officially launched! Learn more now.

Install CMS 5 After installing CMS 6

Vote:
 

Hi!

I was wondering on how to install CMS 5 when CMS 6 is already installed. Can I add new versions to the EPiServer Deployment Center?

I tried to run the installation program for CMS 5 but it crashed with the following error

Launching EPiServerShared.msi /i "C:\incoming\EPiServer CMS 5.2.375.236(2)\EPiServer CMS 5.2.375.236\EPiServerShared.msi" /passive /norestart /lv+ "C:\incoming\EPiServer CMS 5.2.375.236(2)\EPiServer CMS 5.2.375.236\EPiServerShared.msi 2010-03-21T08 06 18 Setup.msi.log" LICENSE_ACCEPTED=1 SQLEXPRESS_INSTALLED=MSSQL10.SQLEXPRESS SQLSERVER_INSTALLED=MSSQL.1
msiexec returned 1603
Setup.exe Error: 0 : System.Configuration.Install.InstallException: EPiServer Shared Services failed to install. Aborting the installation.
   at Setup.Installers.MsiInstaller.Install(IDictionary stateSaver)
   at System.Configuration.Install.Installer.Install(IDictionary stateSaver)
   at Setup.Forms.Splash.DoInstall()
Showing error: EPiServer Shared Services failed to install. Aborting the installation.

I'm running on a Vista Ultimate 64 bit.

/Dan

#37816
Mar 21, 2010 8:18
Vote:
 

When I look in the log for the sharedServices install, it fails because cms 6 installed a newer version

MSI (s) (A8:04) [08:06:44:685]: Product: EPiServer Shared 1.1.21.0 -- A newer version of EPiServer Shared Components is already installed.

Action ended 08:06:44: PreventDowngrading. Return value 3.

 

Is it possible to run a cms 5 and cms6 on the same machine at all?

#37817
Mar 21, 2010 8:29
Vote:
 

If I run the EPiServerCMS.msi package (from the installation zip) it only installed the installation files and the CMS5 version was available in the Deployment Center and I could install a new site.

Will there be any problem using the CMS 5 site when the shared services is the ss that comes with CMS6 RC1?

/Dan

#37818
Mar 21, 2010 8:39
Vote:
 

I'm running both CMS 5 R2 and CMS 6 RC on the same machine. I would try to install CMS 5 first, then CMS 6. See if that helps.

Frederik

#37819
Mar 21, 2010 9:22
Vote:
 

The error you see is because we added "downgrade" protection in the EPiServerShared installer. EPiServerShared is essentially deployment center, scheduler, indexing and log service. We only allow one installed instance of EPiServerShared and it must never be downgraded to a lower version. What this means is that your solution, just to install EPiServerCMS.msi will do the trick, you already have the latest EPiServerShared installed. What this leads to (i think) is that you won't be able to select "Express" install in the wizard. To get around this, you can replace the EPiServerShared.msi in the R2 installation folder with the one that sits in the CMS 6 installation folder and run setup.exe.

I hope this makes sense.

 

#37963
Mar 24, 2010 20:58
Vote:
 

FYI. Got the same issue when trying to install EPiServer Relate+ after installing EPiServer CMS 6. I ran the EPiServerRelatePlus.msi and it worked. Thanks Fredrik T.

#38703
Apr 19, 2010 18:54
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.