Virtual Happy Hour this month, Jun 28, we'll be getting a sneak preview at our soon to launch SaaS CMS!

Try our conversational search powered by Generative AI!

VPP 404 issue

Vote:
 

Hi,

 

I am having a strange issue with VPP folders returning 404 errors.

I have a Virtual Path Native Provider mapped to a server drive.

Files can be uploaded in edit mode correctly.

however, when I try and view them in a browser, I am unable to load anything but image (png) files.

.txt, and .pdf files return 404, even though they exist in the directory.

Any ideas please?

#50577
May 04, 2011 16:50
Vote:
 
You need to add the path in web.config Also. Like global and documents
#50579
May 04, 2011 17:46
Vote:
 

Global and Documetns don't have paths in web.config, apart from the <add path.... part, which is present in the one that is causing the issues:
The paths are mapped in episerver.config

  <location path="Documents" inheritInChildApplications="false">
    <system.web>
      <!-- Setup the StaticFileHandler for the wildcard mapping to work in IIS6 -->
      <httpHandlers> 
        <add path="WebResource.axd" verb="GET" type="System.Web.Handlers.AssemblyResourceLoader" validate="true" />
        <add path="*" verb="*" type="EPiServer.Web.StaticFileHandler, EPiServer" validate="true" />
      </httpHandlers>
    </system.web>
    <staticFile expirationTime="-1.0:0:0" />
  </location>
  <location path="Global" inheritInChildApplications="false">
    <system.web>
      <!-- Setup the StaticFileHandler for the wildcard mapping to work in IIS6 -->
      <httpHandlers>
        <add path="WebResource.axd" verb="GET" type="System.Web.Handlers.AssemblyResourceLoader" validate="true" />
        <add path="*" verb="*" type="EPiServer.Web.StaticFileHandler, EPiServer" validate="true" />
      </httpHandlers>
    </system.web>
    <staticFile expirationTime="-1.0:0:0" />
  </location>

       <location path="Otherfiles">
    <system.webServer>
      <handlers>
        <add name="webresources" path="WebResource.axd" verb="GET" type="System.Web.Handlers.AssemblyResourceLoader" />
        <add name="wildcard" path="*" verb="*" type="EPiServer.Web.StaticFileHandler, EPiServer" />
      </handlers>
    </system.webServer>
    <staticFile expirationTime="-1.0:0:0" />
  </location>

    

#50580
Edited, May 04, 2011 17:57
Vote:
 

Is the site running on IIS6 or IIS7?

If you look in your config above you can see that Documents and Global are configured with IIS6 syntax (<system.web><httpHandlers>) while OtherFiles is configured with IIS7 syntax (<system.webServer><handlers>). Try to change the settings for OtherFiles to use IIS6 syntax.

#50596
May 05, 2011 7:46
Vote:
 

Thanks Johan,

I was using IIS6, and changing that solved my issue.

#50598
May 05, 2011 8:57
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.