Vulnerability in EPiServer.Forms

Try our conversational search powered by Generative AI!

Failed to copy the page

Vote:
 

I am having trouble coping pages in a EPiServer site that has recently been upgraded to CMS6 R2.

The background job fails with the error message:

"Failed to copy the page "foo" beneath the page "bar". Copying a page requires permission to create new pages beneath the destination page."

The user i am logged in does have permission to create pages under the taget page though... I have tried creating new pages there and it works fine. If I alow the group "Everyone" to create pages it also works to copy pages so it defenatly seems to be permission related.

The site is using the MultiplexingMembershipProvider with WindowsMembershipProvider and EPiServerCommonMembershipProvider.

Any tips on what i am doing wrong or how to troubleshoot this further?

#50295
Apr 26, 2011 15:46
Vote:
 

Does it fail when you try and start it manually with the user that had access rights to create a page?

If it's only when running automatically then you could create a system user that has the rights you want it to have and then elevate the user rights for the job by letting the code run with that user.

PrincipalInfo.CurrentPrincipal = PrincipalInfo.CreatePrincipal("sysUser"); ;

 

#50296
Apr 26, 2011 16:09
Vote:
 

It sounds to me that you are referring to a scheduled job. Isen't background jobs as it is called in the EPiServer UI something different?

The UI for displaying the result of the jobs is located in EPiServer.UI.Edit.BackgroundJobs but I haven't found any information on how these are actually run.

 

#50311
Apr 27, 2011 9:46
Vote:
 

Right you are. Was thinking about the scheduled job. So the issue arise when you try and copy and paste a page in the  UI then?

#50312
Apr 27, 2011 10:05
Vote:
 

Yes, and i can create a new page in the destination so i should have the appropriate access rights.

It would be interesting to know how the background jobs is run to see if it might be related to the site using the multiplexingprovider or something like that.

#50313
Apr 27, 2011 10:30
Vote:
 

Interesting. Well it's not something I'm able to reproduce using the standard templates. Guessing you should run it by EPiSupport and give them the details about your pagetypes and so on.

#50314
Apr 27, 2011 10:49
Vote:
 

One idea to get more information around the issue can be to turn on log4net logging and see if that gives more detailed information.

 

 

#50321
Apr 27, 2011 13:16
Vote:
 

I have tried to turn logging to "All" but all i get is the SQL-statement used to get the error-report unfortunately.

#50325
Apr 27, 2011 14:48
Vote:
 

In the enviroment where this error is occuring we also have windows authentication. When I turn that off, copying pages seem to work again ...

#50369
Apr 29, 2011 9:28
Vote:
 

I have reported a bug for this so someone will take a look at it, 

Bug #64845: Impersonation during copy does not work when using Windows authentication
#50419
Edited, May 02, 2011 7:28
Vote:
 

Hi,

I've got the same problem. However it won't work even if I turn off Windows Authentication.

According to the bug list the issue is fixed:
"This is reported from a forum post (see attached link), I have not tried to reproduce it.

From the post it seems like the impersonation from request thread to background thread does not work when running with windows authentication."
 
Are there a hotfix or does anyone have a solution with slightly more information? =)

Edit:
Cut and Create works fine.
#52369
Edited, Jul 20, 2011 10:57
Vote:
 

Yes, there is a hotfix for it. You will have to request it from EPiServer though since its not a part of any official release yet.

It seems cut and copy page is implemented differently and thats why cut works.

#52374
Jul 20, 2011 13:19
Vote:
 

Hi,

Having a similar error now, but not with Windows Authentication enabled. The background job says "Failed to copy the page "Test page" beneath the page "Test page 2". The page type is allowed under "Test page 2" and the user has sufficent access rights.

The only thing I can find in the log is this:

2011-12-06 14:08:44,555 INFO [PipeServerChannel.ServerMain] EPiServer.DataAbstraction.ScheduledJob.Execute - 3.1.3  Scheduled job has already been executed 8de3f2b0-6e12-4716-a6f9-736f7e2f8944

The job "Publish delayed versions" had hung up, but that didn't fix the problem.

So where should I look now?

#55523
Dec 06, 2011 14:31
Vote:
 
The hotfixed DLL (file version 6.1.379.60) for "Bug #64845: Impersonation during copy does not work when using Windows authentication" unfortunately contains another bug. The copy/paste job will only succeed for users with administer permissions. Contact EPiServer to get a hold of the new hotfix (file version 6.1.379.61).
#56311
Jan 17, 2012 14:29
Vote:
 

Hi,

How do I req this hotfix?

 

 

#56328
Edited, Jan 18, 2012 9:12
Vote:
 

Request it from EPiServer Support

#56329
Jan 18, 2012 9:35
Vote:
 

I'm experiencing the same error. I have contacted Episerver support for hotfix.

#56927
Feb 16, 2012 11:42
Vote:
 
#56928
Edited, Feb 16, 2012 11:44
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.