Try our conversational search powered by Generative AI!

SharePoint Connector


Hi everyone

I'm currently trying to set up the SharePoint Connector. I installed the Connector and when I go to the File Manager the SharePoint folder is present. Unfortunately when I open it, it says "A license error for the selected virtual path provider prevents it from displaying properly. [ No Valid License Found].

I did not enter a license file during the installation, so thats probably the issue. I don't know which file is referred to and where I am supposed to place this. 

Any help would be appreciated!

Sep 04, 2011 21:51

Okay, I figured it out, kinda stupid, but I'll post the solution for others...

You need a separate file from the site, I then reïnstalled and provided the file... 

Unfortunatly I'm still stuck with this connector :s Am I supposed to configure a Content Channel? and what other configurations am I supposed to make? If I now go to the File Manager, it just says "A folder for this page has not been created, do you wish to create one now?" Clicking the "Create page folder" doesn't do anything :s

Any help would be appreciated!!!

Sep 04, 2011 22:49

Hi Veerle,

If you want to access SharePoint files from CMS File Manager - all you need to do is to configure Virtual Path Provider for SharePoint as it is described in installation instructions here.  The message "A folder for this page has not been created, ..." could mean that you have a wrong SharePoint server URL or Document Library name. Please check Virtual Path provider for SharePoint configuration in episerver.config, it should look like:


<add name="SharePointFiles" showInFileManager="true" bypassAccessCheck="false"
  virtualPath="~/SharePoint/" isMOSS="False" wssSiteUrl="http://vm-sp"
  wssDomainName="" wssLogin="Administrator" wssPassword="p@ss1word" useImpersonation="false"
  virtualName="SharePoint" customFileSummary="~/WSSFileSummary.config"
  useCache="True" cacheExpirationTime="30"
  wssRootFolder="Shared Documents" />


Please check wssSiteUrl value - it should have proper link to the SharePoint server, wssDomainName and wssLogin and wssPassword  - should have proper SharePoint credentials, wssRootFolder - should have a proper SharePoint document library name or can be emtpy.

Sep 05, 2011 9:11

Thanks for your reply!


I ran through those installation instructions but couldn't find where exactly to find the virtual path configuration, so thank you for that. I checked the episerver.config file and I have everything seems okay. I did have to add the "wssRootFolder" property but adding that didn't change anything. I still get the same error in the File Manager.

Could my EPiServer & SharePoint Content Channel be missconfigured? When I try to send content I get errors syaing there were no virtualPathProviders configured to handle the virtual path... I currently have a Library Boekenlijst and a library Shared Documents and I get errors "There is no VirtualPathProvider configured to handle virtual path ~/SharePoint/Boekenlijst/filename.docx, same for Shared Documents... Am I supposed to make a virtual path in the episerver.config for each of these, so ~/SharePoint/Boekenlijst and ~/SharePoint/Shared Documents???


Thanks in advance

Sep 05, 2011 12:05
Well, usage of the content channel is a different story. In Connect for SharePoint module there are two main functions:
First one - Virtual Path Provider for SharePoint which is capable to show the content of the SharePoint document libraries in CMS File Manager. In Virtual Path Provider for SharePoint the content is just displayed in CMS File Manager without actually copying it to the CMS and this does not require any specific configuration on the SharePoint side (unless you are planing to use advanced security) .
Second one - pushing the content (list items and files) from the SharePoint server to the CMS over content channels. In that case SharePoint server content is copied to and maintained in synchronization with CMS. In order to use it you need to install SharePoint solution (SharepointConnector.wsp), configure content channel in CMS and set the virtual path for pushed files (“Virtual root for files” field in Content Channel configuration).
So, which function do you want to use?
In order to find what kind of problem you have with VPP for SharePoint try to enable debug level logging in CMS and check what is logged for the EPiServer.VirtualPathWssProvider type. For the second function try to enable SharePoint  logging as it described here.
Sep 05, 2011 13:37

Well I'm actually trying both :P


I will try debugging in a minute, but if I understand correct both functions require the VVPs and since neither of the functions work, couldn't I just presume the problem lays with the VVPs?

Sep 05, 2011 13:51

Content Channel does not require VPP for SharePoint, it can be configured to use any VPP and usually a local CMS file storage is used (like ~/Global/ or ~/Documents/).

Sep 05, 2011 14:23

Although I'm not entirely sure what I changed, but it works now! I reïnstalled the Connector and now both functions work :)

Thank you Sergii for your answers and explanation!

Sep 05, 2011 14:41

I have one more question :p

In the second function of pushing the content from SharePoint to EPiServer, I receive two libraries, which is correct because that is how I set the Channel.

In the first function of just showing content from SharePoint in EPiServer, I receive several libraries (Site Assets and Style Library aswell), but when I create a new library this is not shown. How does this work, how is determined which content is shown and which is not?



Sep 05, 2011 14:47

Never mind, I see now that only Libraries are shown.

Once again thank you for your help!

Sep 05, 2011 14:50
To be precise only this types of libraries are supported by VPP for SharePoint:
Documents library
Pictures library
Forms library
Sep 05, 2011 14:57
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.