Problem with installing site on Windows 8


I run:

Windows 8
IIS 8 (which should have good backwards compatibility)
SQL Server Express 2008

I'm trying to install a new site through the Deployment Center.

Everything seems to be working fine until the commit phase starts (or at least that's when I get the error message).

Here it is:


Entering commit phase


An unhandled error has occured:
Class not registered
When executing

At C:\Program Files (x86)\EPiServer\CMS\6.1.379.0\Install\System Scripts\Instal
l Site (SqlServer).ps1:163 char:21
+ $wizard.LaunchSite <<<< ()


At C:\Program Files (x86)\EPiServer\CMS\6.1.379.0\Install\System Scripts\Install Site (SqlServer).ps1:163 char:21
+ $wizard.LaunchSite <<<< ()
System.Management.Automation.ParentContainsErrorRecordException: Exception calling "LaunchSite" with "0" argument(s): "Class not registered"


So, something wrong obviously happens in the "Install Site (SqlServer).ps1" script.

These are the lines the Error message points to:


161 if ((Get-EPiWebServer).GetVersion() -gt 5)
162 {
163     $wizard.LaunchSite()
164 }
165 else
166 {
167      # Make sure System.Windows.Forms is loaded
168      [void][System.Reflection.Assembly]::Load("System.Windows.Forms, Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089")
170      [void][System.Windows.Forms.MessageBox]::Show($resources.GetString("WinXPStartSiteManually"), $resources.GetString("WarningCaption"), 
171      [System.Windows.Forms.MessageBoxButtons]::OK,[System.Windows.Forms.MessageBoxIcon]::Warning) 
172 }


But, I don't know how to solve this. :(


Can someone help? :)


Aug 30, 2012 10:34

Ok, I thought the HTTP Error 500.19 I got when I tried to open the site was caused by the error in the OT, so I focused on the that one.

But, the HTTP Error 500.19 was caused by not adding the feature .Net 3.5 under IIS. So now it works.

I still get the error in the OT, but everything else seems to work fine, so I'll just ignore it for now. 


Aug 30, 2012 11:09

IIS 8 has good backwards compatibility but our installer code in CMS 6 R2 was not very forward compatible :) It works fine in EPiServer 7 even though the public preview has a slight bug when it asks you to install IIS and won't add the .NET 4.5 component. I guess you experienced the same problem, the error message that you get is far from helpful when you don't have the correct ASP.NET integration is place.

Aug 30, 2012 12:23
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.