SaaS CMS has officially launched! Learn more now.

EPiServer FTS issues



Im using EPiServer Full Text Search on a EPiServer CMS 6 R2 installation. I'm mostly using it to search pages rather then files, seems to be an issue with files and FTS at the moment.

Locally on my Windows 7 installation with IIS7, im getting search results and everything works dandy. But when moving to the staging server, which has Windows 2008 R2, im getting 0 results. The index files are created and the ReIndex gadget works.

I've been pulling my hair on this, but finally located what might be the issue.

1 hit on the page that i'm looking for. 


Here im getting a login (when using Forms or Windows) that my administraor credentials fails on.


Been trying to to remove authentication on the location path for IndexingService.svc but still it gives me a login. Any ideas what this might be?

Feb 21, 2013 15:02

Hello Viktor are you trying to access the staging URL from the server or your local machine?

By default the <clients> section of <> will only allow requests from local addresses. You could try RDP'ing to the staging machine and see if you get any results. You will need to ensure "staging" resolves to if it doesn't already.

Or can add the IP address of your dev machine to the ipAddress attribute.

See this note for more info on the <clients> element of <>:


Feb 21, 2013 17:51

That seems to be the issue! Thank you. I can access the search results from staging but I can't get the IP-range to work. Preferrably I would want from to Which should be "" right? Doesn't seem to work. It works when I put the specific IP-adress of the computer i'm trying to access from it works.


Any ideas?

Feb 22, 2013 10:28

No, it's the other way around. In CIDR notation the prefix size (after the slash) specifies how many bits are part of the prefix.

/32 means the entire address is included (and then only that exact address will match in a comparison), /0 means nothing is included (and then anything will match).

Feb 22, 2013 10:57

Thank you! Now i'm finally getting results from the API atleast in the staging. I'm still not getting any results from staging using:

var fieldQueryResult = SearchHandler.Instance.GetSearchResults(fieldQuery, 1, 1000);

But on my local dev machine i'm getting results with a copy of the staging database, and the same size on the index. No errors in the log, just getting .. 0 results.


Edited, Feb 22, 2013 12:01

try to copy the index as well. Or recreate the index. Think there is a gadget for reindex content for the FTS released by Paul Smith.

Feb 26, 2013 11:07

Tried copying the index, same results. Reindexed as well, no issues there. No results. Is there any requirements on Windows Server 2008 R2 that i've missed? 

Feb 26, 2013 12:25
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.