Virtual Happy Hour this month, Jun 28, we'll be getting a sneak preview at our soon to launch SaaS CMS!

Try our conversational search powered by Generative AI!

Could not load file or assembly 'EPiServer.ApplicationModules'

Vote:
 

Hello! I'm trying to set an episerver 6 site, but i get this error: 

Could not load file or assembly 'EPiServer.ApplicationModules' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)

I've checked EPiServer.ApplicationModules, it finds all of its dependencies. I tried reinstalling .NET as well, but I still have the same error.

Does anyone know what it is?

#69135
Mar 22, 2013 12:30
Vote:
 

Do you set it up by using deployment center? Have you installed the alloy tech demo site or just created an empty site?

#69178
Mar 25, 2013 11:20
Vote:
 

I have also run into this problem. it needs EPiServer.ApplicationModules in version 7.0.859.1 but i only have version 6.2.267.1 in my project. where to get the right version?

#82155
Mar 06, 2014 9:06
Vote:
 

@ Ida should exist here - C:\Program Files (x86)\EPiServer\Framework\7.0.859.1\bin  ?

#83959
Mar 31, 2014 9:52
Vote:
 

EPiServer.ApplicationModules comes together with `EPiServer.Framework` NuGet package. If you haven't installed EPiServer libraries via NuGet - do it, if you have installed and still missing `EPiServer.ApplicationModules` file - either copy over from `/packages/EPiServer.Framework.6.2.267.1/lib/` or reinstall package once again.

#84311
Mar 31, 2014 14:17
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.