Try our conversational search powered by Generative AI!

Episerver CMS 6 R2 Issue



I have installed Episerver CMS 6  r2 on windows 8 machine and the installation was all good. Then I go to the home page i get "There is only core installation files exists" message. I refresh the page again i get to page with this error. As I am new to the whole episerver and ASP.NET. any help would be highly appreciated. I use IIS 8 , windows 8 and below is the error i get. 




Object reference not set to an instance of an object. Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.NullReferenceException: Object reference not set to an instance of an object.

Source Error:

[No relevant source lines]

Source File: c:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\root\ba867242\bf776f75\App_Web_2cpigfbr.0.cs    Line: 0

Stack Trace:

[NullReferenceException: Object reference not set to an instance of an object.]
   EPiServer.Configuration.Settings.get_Instance() +24
   EPiServer.PageBase..cctor() +37

[TypeInitializationException: The type initializer for 'EPiServer.PageBase' threw an exception.]
   EPiServer.PageBase.OnPageSetup() +18
   EPiServer.PageBase..ctor(Int32 enable, Int32 disable) +106
   EPiServer.EditPage..ctor(Int32 enable, Int32 disable) +155
   EPiServer.Templates.Default..ctor() +26
   ASP.default_aspx..ctor() in c:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\root\ba867242\bf776f75\App_Web_2cpigfbr.0.cs:0
   __ASP.FastObjectFactory_app_web_2cpigfbr.Create_ASP_default_aspx() in c:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\root\ba867242\bf776f75\App_Web_2cpigfbr.1.cs:0
   System.Web.Compilation.BuildResultCompiledType.CreateInstance() +30
   System.Web.Compilation.BuildManager.CreateInstanceFromVirtualPath(VirtualPath virtualPath, Type requiredBaseType, HttpContext context, Boolean allowCrossApp) +100
   System.Web.UI.PageHandlerFactory.GetHandlerHelper(HttpContext context, String requestType, VirtualPath virtualPath, String physicalPath) +31
   System.Web.UI.PageHandlerFactory.GetHandler(HttpContext context, String requestType, String virtualPath, String path) +37
   System.Web.MaterializeHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +346
   System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +155
Jun 04, 2014 3:13


Are you able to access edit mode? http://Yoururl/YourSecretToUI/Edit/default.aspx?

Did you install the alloy templates or was it just an core application installation?

If you can access editmode then you could create a page and then go into episerver.config and set this pages id (you can see it from hoverning the created page) as the startpageId

Jun 04, 2014 7:42

You can get that type of error if you have a default.htm file in the root. If you have try to remove it.

Jun 04, 2014 9:19


Thanks for your replies. @Per I have already removed the default.htm file.

@petter - I have tried accessing the page and it said resource not found, i have tried installing alloytech site and new installation of both episerver 6 r2 as well, still get the same error.



Edited, Jun 06, 2014 3:48
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.