SaaS CMS has officially launched! Learn more now.

System Requirements - EPiServer CMS 5 R2 SP2

SERVER REQUIREMENTS

Operating system

Any of the following is required:

  • Microsoft Windows Server 2003 SP2 32/64 bit
  • Microsoft Windows Server 2008 SP2 32/64 bit
  • Microsoft Windows Server 2008 R2

Web server

  • Microsoft Internet Information Services (IIS) 6.0, 7.0 or 7.5 must be installed as part of the Windows Server installation.

Database

Any of the following is required:

  • Microsoft SQL Server 2005 SP2 32/64 bit
  • Microsoft SQL Server 2008 SP1 32/64 bit
  • Oracle 9i 32 bit (Windows server) *
  • Oracle 10g R2 32/64 bit (Windows server) *
  • Oracle 11g 32/64 bit (Windows server) *

* Oracle Data Provider for .NET only exists in 32-bit, which means that EPiServer CMS can be only installed on a 32-bit server. Read more in the Oracle Configuration tech note..

Other requirements

Any of the following is required:

  • Microsoft .NET Framework 3.5 SP1
 

CLIENT REQUIREMENTS FOR EDITING

Operating system

Any of the following is required:

  • Microsoft Windows XP SP3
  • Microsoft Windows Vista SP2
  • Microsoft Windows 7
  • Mac OSX 10.5 or later

Browser for editing

Any of the following is required:

  • Microsoft Internet Explorer 6.0
  • Microsoft Internet Explorer 7.0
  • Microsoft Internet Explorer 8.0
  • Firefox 3 (limited support)

Microsoft Office 2003/2007 (32 bit only) and Microsoft Internet Explorer in Windows XP or Vista is required to publish from Microsoft Office to EPiServer CMS 5.

 

CLIENT REQUIREMENTS FOR BROWSING

Browser for viewing

All major browsers are supported, including:

  • Microsoft Internet Explorer
  • Mozilla Firefox
  • Netscape
  • Google Chrome, Opera, Safari

NOTE Browsers supported for viewing are entirely dependent on the construction of the EPiServer CMS 5 templates.

 
 

DEVELOPMENT AND DEMONSTRATION ENVIRONMENT

Operating system

Any of the following is required:

  • Microsoft Windows XP SP3 32 bit
  • Microsoft Windows Vista SP2 32/64 bit
  • Microsoft Windows 7 32/64 bit
  • Microsoft Windows Server 2003 SP2 32/64 bit
  • Microsoft Windows Server 2008 SP2 32/64 bit
  • Microsoft Windows Server 2008 R2

Development tool

  • Microsoft Visual Studio 2008 SP1
  • Visual Web Developer 2008 Express Edition SP1

Database

Any of the following is required:

  • Microsoft SQL Server 2005 SP2
  • Microsoft SQL Server 2005 SP2 Express
  • Microsoft SQL Server 2008 SP1
  • Microsoft SQL Server 2008 SP1 Express
  • Oracle 9i R2 32 bit *
  • Oracle 10g R2 32/64 bit *
  • Oracle 11g 32/64 bit *
  • Oracle 10g R2 Express Edition *

* The EPiServer Visual Studio integration SDK installation requires Microsoft SQL Server Express.