Virtual Happy Hour this month, Jun 28, we'll be getting a sneak preview at our soon to launch SaaS CMS!

Try our conversational search powered by Generative AI!

Addon-tab crash (addon-store update 3.1.0)


EPiServer 7.6 

The add-on tab havnt worked since we upgraded to 7.5

We downloaded the addon-store nuget (3.1.0) package to fix the new path and move addons to the new _protected folder. 
It all works localy on my dev. computer.. i can view all the addons on the site in the add-ons tab.

But the addon-tab crashes on the server when I try to view either of:
"Episerver add-ons"
"Episerver beta"
"Third-Party addons"

I get the following message:

  • Error reading add-ons list RequestError: Unable to load /episerver/AddOns/AddOns/GetInstallableModules?moduleArea=EPiServer.Packaging.UI status: 500

We currently got one third party -addon that I successfully uploaded from my local computer. And it seems to be working on the server too .. I can view the "Installed" section in the add-on ui 

Is there som changes I need to make in the VPP folder on the server? Last time we published we deleted all the existing items. And we cant just copy the whole VPP from local for obvious reasons.

I tried to follow all the steps in the readme (the one from the addon-store nuget). But I cant remember any changes in the VPP. 

Anyone got some suggestions on what the problem might be ?

Mar 21, 2014 10:28

Hi Erik,

Did you fix this? I'm having the same problem.


May 07, 2014 12:26

Do you have any more information about the actual exception?
Message, callstack, etc.

Most likely there are stale files in either modulesbin or [appData]\Modules.

May 08, 2014 10:40

A normal problem is that you have deleted or updated www/modules, www/modulesbin or appdata/Modules, appdata/ModulesRepository. 

These are the interesting folders when having addons. If you wipe either of these when you do a deploy, you will likely have a problem with addons not working. My best guess is that you have wiped or modified one of these manually (not by installing / updating an addon by the admin interface). 

A more rare error is that you have copied a addon dll to bin folder which is an equal no no...

Workaround to get it up and running again. Install addons you want locally. Copy these folders above to your server that has a problem. Note though that the install event for the addon will likely not run when doing this workaround so some addons might not work when doing this.

Workaround if having this problem. Only install EPiServer addons on dev server. Copy these to production server. Reinstall the other addons by using admin interface after this (install event for these addons will then run which will allow them to initialize database / dds or similar)

Hope that will help someone... 

May 09, 2014 9:09

Try running Chrome Dev Tools or Firefox Firebug to capture network requests and see what is the server response body when you get that
Error reading add-ons list RequestError: Unable to load /episerver/AddOns/AddOns/GetInstallableModules?moduleArea=EPiServer.Packaging.UI status: 500
I think you will see ASP.NET error page with details that will help to fix the problem.

My guess is that IIS process does not have modify access rights to folders where add-ons are deployed (add-on repositories, public and protected add-on folders, modulesbin and temporary folder).

May 09, 2014 10:26


We updated one of our customer to the latest version of EPi and EPiFind. All is fine and dandy in our developer site, but in test the addon-tab doesn't work. I don't get any error messages or exception. It just takes forever to load. 

I did a test with Chrome dev tools and captured the network requests. I saw that it got stuck on “GetInstalledModules?moduleArea=EPiServer.Packing.UI” and that it took 2.3 hours to get a response. 

Epi and Epi.find is running the following verions:

EPiServer.CMS.Core 7.19.1 


EPiServer.CMS.UI.Core 7.19.0

EPiServer.Framework 7.19.1

EPiServer.Packaging 3.2.0

EPiServer.Packaging.UI 3.2.0

EPi.Find is 

Has anyone else encountered this?

Edited, Feb 04, 2015 8:09
<p>Hi, haven't seen it myself, though sounds like some &nbsp;files might not be getting updated to test env.<br /><br />How about renaming your&nbsp;modules folder under&nbsp;wwwroot in test env. and xcopying up your modules folder from development to test<br />do the same for Bin folder, packages.config and module.config under&nbsp;wwwroot.<br /><br /></p> <p></p>
Feb 04, 2015 9:32

I've tried that, but no difference. 

One thing I just tried was to manually remove all addons from appdata/modules and appdata/modulesrepsoitory, except for Imagevault and Newtonsoft.Json. Update packages.config and remove the dll files from modulesbin folder in wwwroot/. After that I could open the addons tab and see the two addons for Imagevault and Newtonsoft.json. But it is really slow and when I click on "EPiServer Add-ons", "Third-party add-ons" or anything else in the left menu nothing happens.  

Could it be something with the web server that is causing the add-ons tab to fail? Firewall, proxy or something else? 

The test env is load balanced and it isn't open for public access. 

Feb 04, 2015 13:34
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.