Virtual Happy Hour this month, Jun 28, we'll be getting a sneak preview at our soon to launch SaaS CMS!

Try our conversational search powered by Generative AI!

EPiServer UI - EPiServer 7.5 - All properties view does not open in Chrome

Vote:
 

We have been having some issues recently with EPiServer backend UI where the all properties view does not open. No error is being logged in browser console. It seems to work in Firefox. 

Has anybody else been having this issue and knows a fix? Upgrading to the latest version of EPiServer might not be ideal at the moment and we might need some time to prepare.

#150551
Jun 22, 2016 12:43
Vote:
 

Hi.  We've experience this recently after upgrade from epi CMS 8.11.0 to CMS 9.8.2.

#150553
Edited, Jun 22, 2016 12:53
Vote:
 

Latest chrome version seem to have issues with edit mode for Episerver 9. Use other browser as workaround...

#150556
Jun 22, 2016 13:02
Vote:
 

Thank you for your reply. 

Do you know if there is a bug report filed to Google for this issue?

#150557
Jun 22, 2016 13:42
Vote:
 

You can see some more information here

http://world.episerver.com/forum/developer-forum/-Episerver-75-CMS/Thread-Container/2016/6/chrome-51---edit-interface/

Not sure if it affect 9.8.2 though...

#150563
Jun 22, 2016 15:08
Vote:
 

We have EPiServer.CMS.UI version 7.12.1 . Will this update fix it? Also, I don't get any errors in the console, not using beta version of Chrome and also can't see any issue in systest environment!

#150565
Jun 22, 2016 15:23
Vote:
 

This bug indicates you need to update to 7.19 at least from what I can tell to get Chrome to work good.

http://world.episerver.com/support/Bug-list/bug/CMS-3671

#150568
Jun 22, 2016 15:46
Vote:
 

We have issues with Chrome and latest Episerver 9 updates too. After some work in edit mode it becomes frozen: no buttons work. Very annoying if you work a lot in the edit mode, you need to refresh a page to work again. Unfortunately we can't find steps to reproduce, so we can't post a bug to Episerver.

#150597
Jun 23, 2016 10:30
Vote:
 

Hi,

When Edit mode freezed, do you see any requests that hasn't finished loaded in the network tabs?

Can you see if the CPU for the process for that tab is working hard?

#150664
Edited, Jun 27, 2016 12:01
Vote:
 
<p>We have the same problem, I contacted the episerver support but they said that they couldn't reproduce it...anyhow, I sent them a link to this thread. Nice to see that im&nbsp;not alone... :)</p>
#150673
Jun 27, 2016 15:13
Vote:
 

I attached the following error description to the support:

Sometimes when I create content/navigate around in edit mode and pressing the "All properties button", the page just reloads instead of loading the edit view.

If I try to press the button again, the same problem occurs. 
However, if I do a new GET request of the page(by reloading with F5) and then pressing the button, it will work.

The bug doesn't happen all the time so it's hard to reproduce it but it still happens often enough to be annoying.

When it happens, no errors are shown in the console/network tab in the developer tools.

I tried to reproduce it in Firefox with no success. So Im guessing this is Chrome related.

Have you heard of any similar bugs? Any tips of how to debug this further?

It seems to happen(not all the time though) when doing something like this: 
Click add new block in a Content Area 
Select a block that contains a Content Area as well 
Add a few blocks to the blocks content area 
Publish the block 
You will now be taken back to the Page and get the message that the page has unpublished content. 
If now trying to go to the "All properties mode", the page will just reload instead of loading the edit mode.

#150676
Jun 27, 2016 15:22
Vote:
 

Could you try and update chrome to the latest version? I've spent quite some time(together with our QA manager as well) to reproduce it on chrome version 51.0.2704.106 m now and it looks like the problem is gone. We first started to notice this about 2-3 weeks ago and then we could reproduce it within like 2-3 minutes of clicking around in edit mode. Now we can't :)

#150677
Jun 27, 2016 15:38
Vote:
 

In our case, it wouldn't crash. The button would show loading gif for a few seconds then show the in page edit mode again. There's been a new update for Chrome so I'm going to ask the editors to give it a try.

#150687
Jun 27, 2016 16:31
Vote:
 

I have updated chrome yesterday. Logged back in today and the edit mode didn't load at first. Reloaded the page using the button on chrome (like F5) and it worked. So I guess the issue is still there.

#150705
Jun 28, 2016 11:09
Vote:
 

It would be great if you could record a video/gif of the error and post here/send it to EPI support. Since I can't reproduce it anymore I can't make it myself...

#150719
Jun 28, 2016 14:17
Vote:
 

I will do that the next time it happens

#150724
Jun 28, 2016 14:54
Vote:
 

Hi All,

Just to confirm that we're also receiving reports of this issue from our client. We can't replicate it (with concrete replication steps) either though.

Has there been any official acknowledgement from EPiServer?

#151666
Edited, Aug 03, 2016 12:01
Vote:
 

I sent them a video capture of it happening. They advised me to upgrade to a version with the fix. The problem is that I cannot replicate it in systest or dev environment so I will have to upgrade and see if it still happens.

#151667
Aug 03, 2016 12:04
Vote:
 

Hi Reza,

When you say "upgrade to a version with the fix", so this has been officially reported as a bug?

I've had a look through the bug reports and the only two issues what I could see which looked similar are these two:

http://world.episerver.com/support/Bug-list/bug/CMS-3671

http://world.episerver.com/support/Bug-list/bug/CMS-3672

We're running EPiServer 9.9 which is a later version and therefore contains these patches. The issue is still present, so therefore an upgrade probably won't help you..

Thanks,

James

#151672
Aug 03, 2016 14:16
Vote:
 
<p>I reported similar Chrome edit mode issues to Episerver support with error stack traces, but they can't reproduce it for now. I will post updates here if we find a solution. We're testing every Episerver update (now on 121) and Chrome still freezes pretty often while you work&nbsp;in the edit mode and that's really annoying.</p>
#151676
Aug 03, 2016 16:19
Vote:
 

This is the response I got from the support team

There were recent UI issues introduced as a result of Chrome 51. These were fixed in various "flavors" of CMS (7.5, 8, and 9). If you aren't already, it's recommended to update to the latest 7.5 version to get the fixes (http://world.episerver.com/support/Bug-list/bug/CMS-3671)

#151739
Aug 05, 2016 12:29
Vote:
 

We've recently upgraded to 9.8.1 (UI) and 9.12.0 (CMS) version. And since then being reported a huge amount of performance in edit mode some of those are

CMS is frozen or taking long time to switch between pages in edit mode

All properties view loading wrong pages (in case if content editors switch betwen page and it still loads the old page)

Drad and drop content in content areas throwing random errors for differnt user.

Can someone from episerver shed some light what has been changed in the recent version?

But one thing for sure edit mode is lot slower after upgrade.

Thanks

#151830
Aug 08, 2016 13:47
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.