Try our conversational search powered by Generative AI!

AlloyDemo setup issues


Working on the training course EpiServer dev fundamentals.    I am having trouble just installing the AlloyDemo.    During install I get this error.    I am using VS2019 Community on my laptop.

The process cannot access the file 'C:\Users\Local Administrator\source\repos\CMSTraining\packages\EPiServer.CMS.TinyMce.2.8.0\content\modules\_protected\EPiServer.Cms.TinyMce.2.8.0\content\modules\_protected\EPiServer.Cms.TinyMce\' because it is being used by another process.

I've tried deleting the folder, rebooting and using VS in Administrator mode.

Not sure how to resolve, please advise thanks!


Oct 23, 2019 16:10


Please try to setup the code on shorter path like - D:/Project/AlloyDemo and try to run the visual studio as Admin mode. One more thing make sure laptop user account also have the admin access.

Oct 23, 2019 19:07

same result.   I am running vs2019 in admin mode.

The process cannot access the file 'D:\Project\CMSTraining\package\EPiServer.CMS.TinyMce.2.8.0\content\modules\_protected\' because it is being used by another process.

Oct 23, 2019 19:45

Try giving the everyone permission to your project folder.

And also try reinstalling the tinymce package again using the package manager console in vs

Edited, Oct 23, 2019 19:52

When exactly do you see this error? On site startup or on a specific page?

Oct 24, 2019 5:08

Okay I figured out how to get around this...   turns out I just had too much stuff running in the background.   I'm on a relatively new laptop - 1 year.

By disabling start up apps with high to medium impact, I was able to get the AlloyDemo installed.

  1. Open Settings.
  2. Click on Apps.
  3. Click on Startup.
  4. Click the Sort by menu and select the Startup impact option.
  5. Turn off the toggle switch for any application that's not a priority (especially those marked as "High impact").
  6. Restart your computer.

Weird, never had this problem with other nuget packages in VS.

Oct 25, 2019 21:49

Ah, so it's your local system problem.

Oct 26, 2019 6:25
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.