Try our conversational search powered by Generative AI!

Episerver Labs Block Enhancements not working



I get the following error in the browser console when trying to inline edit a block in a content area (a feature from the Episerver Labs Block Enhancements project).

Uncaught Error: No store by the name 'episerver.labs.blockenhancements' exists.
    at Object.get (Registry.js:83)
    at Object.postCreate (block-edit-form-container.js:43)
    at Object.create (_WidgetBase.js:391)
    at Object.postscript (_WidgetBase.js:309)
    at new <anonymous> (dojo.js:4381)
    at Object._execute (inline-edit.js:111)
    at Object.execute (_Command.js:90)
    at Object.onClick (_CommandModelBindingMixin.js:70)
    at Object.onItemClick (_MenuBase.js:258)
    at HTMLTableRowElement.<anonymous> (_MenuBase.js:65)

However, this works fine in the Alloy project so there is something in my project that's causing the issue but I can't find anything and I don't really know where to look.

Has anyone else experienced and solved this issue?

My project is running Episerver CMS 11.20.1 and EPiServer.Labs.BlockEnhancements 0.9.5

Edited, Jan 18, 2021 20:12

Hi Marcus,

Error seems to block enhancements configuration, please visit this article and check.

Jan 19, 2021 2:45
Marcus Utter - Jan 19, 2021 8:10
It does not seem to be an error with the configuration module. I can disable InlineEditing for example and it disappears from the context menu. However, I tried enabling ContentDraftView (i had it disabled) but I don't get the Draft View button.

It probably with your module is not installed properly, try reinstalling it. 

There is one similar error logged here (in below link), but for different thing. So it might give you some hint (if reinstalling don't work)

Otherwise you can raise this issue on git, here


Jan 19, 2021 7:09
Marcus Utter - Jan 19, 2021 13:19
Actually it did work by reinstalling through Update-Packages -reinstall!
Praful Jangid - Jan 19, 2021 13:34
So, it seems like it was not installing properly by any mean. How you installed previously?

I now got it to work by reinstalling the NuGet package through the Package Manager Console using the following command

Update-Package EPiServer.Labs.BlockEnhancements -reinstall

The changes I saw after this was not directly tied to the BlockEnhancements module which I though but to the files in modules/_protected/episerver-telemetry-ui 

Jan 19, 2021 13:18
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.