Try our conversational search powered by Generative AI!

Connect for SharePoint with Office 365


I'm looking to perform an integration between an EPiServer site and SharePoint, and would prefer to use the standard connector if possible.  

I have gone through the documentation, and feel that it is perhaps out of date, or simply missing some details, so if anyone can assist me in filling in the gaps, it would be very helpful.

We generally just need to pull in content from a set of document libraries in sharepoint - no web parts are necessary for this integration.

To attempt a proof of concept, I've:

  • Created a new Allow MVC site.
  • Installed the Connect for SharePoint add-on via NuGet.
  •    This upgraded my install to 8, which is fine if it works, but I'm also fine beginning with a 7.5 site if CMS 8 ends up being part of the problem.
  • Navigating to the add-ons, I see the SharePoint add on is installed.
  • Navigating to the cms admin area, I see the Connect for Sharepoint configuration screen.
  • Entering my credentials for our Office 365 SharePoint instance and clicking connect, I receive the following error shown above the form:
  • "Error when connecting to SharePoint site: The remote server returned an error: (403) Forbidden."

So I was thinking perhaps there is a setting or something that needs to be configured from the SharePoint side, but when I log in I don't see anything obvious.  This page ( does not seem to mention any such thing, despite appearing to be the most recent, but this page ( mentions a SharePointConnector2013.wsp file.  However the nuget package does not include said file, and there doesn't appear to be a download link for the file anywhere that I see.  The file is also referenced only up to the 2013 version, so I'm not sure whether it really applies to the Office 365 version of SharePoint or not.

If anyone has experience getting the Connect for SharePoint module working under CMS 7.5 or 8.0, against SharePoint in Office 365, any insight would be greatly appreciated.  


Aug 11, 2015 22:46

Oh - and I did install the  SharePoint Client Components SDK from as called out here ( although based on the release notes of the latest Connect seem to imply that is no longer necessary ("Changes in for CMS 8: --- Using REST services to avoid dependency to Microsoft Sharepoint Client DLL").  Having the SDK/DLL installed didn't change any behavior.

Thanks again!

Aug 11, 2015 22:58

I'm in the exact same "state" (getting 403-forbidden)

I can't find a better guide than and it feels incomplete??

Please EPiServer, tell us how to configure sharepoint 365 to make this work. 

/Martin Betz

Aug 18, 2015 15:08

New information:

I sent a question about this to the episerver support, and they verified it as a bug in the current version of the Sharepoint connector ( 

No information on when it would be fixed yet.

Sep 10, 2015 13:09


Anything new here? I tried with version and I get the 403-forbidden as well. Couldn't find a registered bug either.

Nov 11, 2015 13:46

Hello Andreas,

When I contacted EPiServer, I was told the bug specifically was that the Connector at that time used the url to detect whether it was accessing an On-Premise or Online version of SharePoint.  If the SharePoint url wasn't the default online one then that detection wouldn't work and the wrong auth method would be used, which would cause the auth to fail with the 403 code.  

To counter that, a new option group was added to the SharePoint Connector configuration screen that allows you to explicitly indicate whether you are connecting to an On-Premise or Online version of SharePoint, rather than attempting to infer that from the url.

The option is present in the newest version of the Connector (  I have installed this version of the connector and can confirm that once I set the Online option, I stopped receiving the 403 I had been seeing.

If you've installed the latest version and are still getting the error, you might be encountering something different than I did. 

Nov 11, 2015 23:23
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.