Vulnerability in EPiServer.Forms

Try our conversational search powered by Generative AI!

EPiServer Forms File Upload

Vote:
 

Hello people! :)

So I installed EPiServer forms and created a form which works, but the problem is the file upload.

How do I upload doc, docx, pdf files?

When I submit the form the only files that it gets is images such as jpg, but when I upload a pdf or docx it doesnt show up in form submissions?

The file extenesions are not blocked, they are allowed, what do I do?

Best Regards

#143712
Jan 29, 2016 9:26
Vote:
 

Just tested this in a plain Alloy 9.2 site with Episerver.Forms 0.19.4.9000 and I get docx and pdf uploads into the form submissions.

You're sure you added the file extensions as comma-separated, with no periods (.) ?

"docx, pdf"

I'm guessing you've tried it with file sizes below the maximum set in your web.config (or in your forms setup) - otherwise you'd get an error when submitting.

Are you getting a submission receipt message at all - are any form data submitted when the form includes a file upload?

Do you have any additional confirmation steps like sending email or something?

#143720
Jan 29, 2016 10:31
Vote:
 

Yes, no periods.

I get no errors att all, "submit successful" is the message I get when submitting so everything is as it should, except it's not working.

I haven't done the email part, I only get the submitted forms in the Form Submissions section for now.

But the files should be included in the form subsmissions if it will be sent by email right?

The images that I upload appears in Forms Submissions, but all other files doesn't appear at all, it shows blank.

#143723
Jan 29, 2016 10:49
Vote:
 

Yes the uploaded files should appear as clickable links in the forms submissions. 

So when submitting, you get the data in, but the file column is blank?

Which version of Episerver and Forms are you on?

#143724
Jan 29, 2016 10:51
Vote:
 

Yes, all blank.

Latest version of both.

EpiServer is 9.6.1 and Forms is 0.21.1.9000

#143725
Edited, Jan 29, 2016 11:11
Vote:
 

Solved the problem!

I didnt have the Generic Media Type model in my project.

http://world.episerver.com/documentation/Items/Developers-Guide/Episerver-CMS/8/Content/Assets-and-media/Media-types-and-templates/

#143740
Jan 29, 2016 13:26
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.