Try our conversational search powered by Generative AI!

Episerver Forms vs. Visual Studio 2015 Update 2



I installed Update 2 for Visual Studio 2015 a couple of days ago. As soon as I opened Manage Packages for Solution Visual Studio crashed. After fiddling around with some settings I ended up removing the Episerver Forms package from the packages.config, and everything seemed OK. But as soon as I tried to add the Forms add-on from nuget Visual Studio crashed again.

Any ideas?


Apr 25, 2016 15:04

Report it as a bug to Episerver, here

Apr 25, 2016 16:18

I had that problem as well, downgraded to a clean VS 2015. I verifed today that this issue is still present in Update 2 unfortunately. Except for Episerver Forms this also happens with Episerver Google Analytics I think.

May 09, 2016 15:02

Strange but can report I have a site with forms and google and update 2 and it is working with updating nugets. Did an update today. Though I have experienced other fun things with nuget and VS2015. I had a custom nuget feed that only worked with VPN connection. If the VPN was not there I could not update any episerver nugets at all only the once that comes from the "builtin" feeds. Once disabled the updates and installations works again.

So for 3 months I actually updated and installed all my projects in VS2013 :) It handled the feeds much better even if the feeds was not available.

May 09, 2016 23:20

We are looking on this. Thank you.
Forms nuget package is quite clean and safe, contain nothing but images, JS, aspx, ... and dll. We even avoid to put .ps1 script into add-on packages.

PS: and if our nuget package can crash the Visual Studio, I think I would file a bug to Microsoft VS team :)

May 10, 2016 6:24

Can you get dump from VS crash?

May 10, 2016 11:12

Yeah I don't think this has anything to do with Episerver, it's a Microsoft issue.

May 10, 2016 11:34

Looks like it's a VS/Windows bug, and that it just happened to reveal itself in combination with en Epi package. Anyhow, the problem is only ln my stationary workstation and not on my laptop, even though thw run the same OS and VS version.

Thanks for all the feedback!

May 10, 2016 18:28
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.