SaaS CMS has officially launched! Learn more now.

Homepage redirect omits the url-parameters

Vote:
 

Hello,

if we use an url that leads to the homepage but has no language in it, Episerver seems to resolve it and redirect to it, for example:
https://www.CompanyName.com/?hashid=1234567

For me i will be redirected to:
https://www.CompanyName.com/en-de/

But what is causing this redirect? I have now installed the developer tools but i can't figure it out.

What we need is that the url-parameters are retained, so for example:
https://www.CompanyName.com/en-de/?hashid=1234567

What i have to do to change the default behaviour of the homepage routing?

Best regards,
Tim

#256380
Edited, Jun 10, 2021 8:56
Vote:
 

If you have multiple languages set up for your site root then you'll be redirected to whatever language you've set up in the admin area maps to that language.

Make sure that you only have 1 language enabled and that you don't have a language set for your domain in the admin -> sites area

#256386
Jun 10, 2021 10:14
Tim Schmelter - Jun 10, 2021 10:22
Thanks for your answer.
The language redirect is fine, my question is about how to avoid that the url-parameter are removed in specific cases(for example the HashId-parameter).
Do i need a IConfigurableModule and handle the RoutesRegistered event to modify the pages route? If so, how?
Scott Reed - Jun 10, 2021 10:26
I've never gone this complex for this sort of thing. I've always just built this is to my URL service as parameter.

You could override the episerver IUrlResolver inherit from the base UrlResolver and add the logic there potentially.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.