Try our conversational search powered by Generative AI!

Error when creating a new category



I'm trying to add a new category from  admin mode in cms 7.

I fill "name" and "description" and hit the save-button, and get this error:

Server Error in '/' Application.

Unable to cast object of type 'System.Web.UI.DataBoundLiteralControl' to type 'System.Web.UI.WebControls.TextBox'.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.InvalidCastException: Unable to cast object of type 'System.Web.UI.DataBoundLiteralControl' to type 'System.Web.UI.WebControls.TextBox'.

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace:

[InvalidCastException: Unable to cast object of type 'System.Web.UI.DataBoundLiteralControl' to type 'System.Web.UI.WebControls.TextBox'.]
EPiServer.UI.Admin.Categories.Save_Click(Object sender, DataGridCommandEventArgs e) +458
System.Web.UI.WebControls.DataGrid.OnBubbleEvent(Object source, EventArgs e) +434
System.Web.UI.WebControls.DataGridItem.OnBubbleEvent(Object source, EventArgs e) +164
System.Web.UI.Control.RaiseBubbleEvent(Object source, EventArgs args) +84
System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +3804

Anybody has an idea why this happens?


Nov 28, 2012 9:00

Strange. I tried it and could create both a new category and a subcatoegory below an already existin one with no problem.

Any special characters in any of the names? Have you tried to create a category with just an "a" as name and description?

Nov 28, 2012 13:35
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.