Don't miss out Virtual Happy Hour this Friday (April 26).

Try our conversational search powered by Generative AI!

xforms - page after submit not showing



I have googled a problem with xforms where the page after submit is not shown.

What I've found so far is that the problem is eigther that smtp settings is wrong
redirect in global.cs is wrong. I tried to solve problems with global.cs by copying
code from a alloy project, but the "submit page" is still not showing.

My customer confirms that the message sent in the xforms schema has arrived
so smtp settings works.

Thanks for all contributions on this problem.

Kind regards,

Jon Haakon

Nov 13, 2012 14:08

We have had problems when the form has contained forbidden characters (EPiServer didn't have so much validation in earlier versions) or the the sender email adress wasn't approved by the smtp servers (failed without any error).


Nov 13, 2012 14:35

Hmm - the form is quit simple. It contains norwegian labels to textfields where user can give feedback on the webpage.

I created a new simple form with textfield navn(name) and Epost(e-mail) both as textfields (in one table column seperate on different cells) and a button in another column.

I specified that sending both email and store in database, entered my own emailaddress as a reveiver and no-reply@[customer].no as from address. And a subject.

After testing this form by hitting the button both fields disappeard leaving only the labels left on screen and "count of votes : 0".

Afterwards, I checked the formdata tab and found nothing when I searched for current paged, but by checking "show data for other pages" the data occred.

I don't think this is how it should work. 

Customer is complaining that many endusers call them to hear if they have receiveed their message.

Nov 15, 2012 16:49

you can check global.asax and global.asax.cs to see if they are inherited from the same namespace.


Nov 15, 2012 19:30

*I'm bowing in the dust* Thank you very much, Huy! Worked like a charm!

... very greatfull! Thanks again! :)

Nov 16, 2012 8:36
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.